Romeo1 Sight Problem - SIG Talk
SIG Talk Gun Forum

Romeo1 Sight Problem

This is a discussion on Romeo1 Sight Problem within the Sig Sauer Optics & Electronics forums, part of the SIG Sauer Forum category; I just bought a new P320 Rx with the Romeo1 sight. While I can get the sight to turn on it has 4 issues: It ...


Go Back   SIG Talk > SIG Sauer Forum > Sig Sauer Optics & Electronics


Sig Sauer Optics & Electronics Sig Sauer Optics forum for all SIG Optics and other related equipment

Reply
 
LinkBack Thread Tools Display Modes
Old 12-06-2016, 04:31 PM   #1
Junior Member
 
Join Date: Dec 2016
Location: Georgia
Posts: 2
Romeo1 Sight Problem

I just bought a new P320 Rx with the Romeo1 sight. While I can get the sight to turn on it has 4 issues: It only turn on by pressing the down button, it will not turn off when pressing either button, it will not turn off when left stationary for 5-10 minutes, and the brightness does not adjust. If anyone else has had similar issues I'd like to know. Either way I will be calling Sig so I will try to leave some feedback on the issue to help someone else in the future. Thanks.
steelernation06 is offline  
Register

Welcome to the SIG Talk Forum dedicated to SIG Sauer Pistols and SIG Sauer Rifles.

We welcome everyone and the community is free to join so register today and become part of the SIG Talk Forum!

Old 12-18-2016, 02:25 PM   #2
Member
 
Join Date: Dec 2016
Location: georgia
Posts: 61
I had that very same problem with a Vortex red dot and it was do to a almost dead battery. I changed the battery per the tech at Vortex and it functions properly now.
sigfan320rx is offline  
Old 12-21-2016, 02:20 PM   #3
Junior Member
 
Join Date: Apr 2015
Location: Newnan Ga
Posts: 3
New here, have a number of Sigs I've been shooting for a few years. Just picked up the Mk25 RX and took it to the range. Weapon shoots beautifully and is dead on using the irons as I would expect. The Romeo 1 shuts off after a couple of rounds and I wasn't able to zero the sight as it would not respond in either elevation or windage. Called Sig, slide is in the mail to them tomorrow. Anyone else had this problem? Thanks.
jetchlnger is offline  
 
Old 12-21-2016, 05:48 PM   #4
Senior Member
 
GoneBallisticInAlabama's Avatar
 
Join Date: May 2013
Location: Alabama
Posts: 13,264
Quote:
Originally Posted by jetchlnger View Post
New here, have a number of Sigs I've been shooting for a few years. Just picked up the Mk25 RX and took it to the range. Weapon shoots beautifully and is dead on using the irons as I would expect. The Romeo 1 shuts off after a couple of rounds and I wasn't able to zero the sight as it would not respond in either elevation or windage. Called Sig, slide is in the mail to them tomorrow. Anyone else had this problem? Thanks.
It has been reported by others.
GoneBallisticInAlabama is offline  
Old 01-02-2017, 03:20 AM   #5
Senior Member
 
DPeter85's Avatar
 
Join Date: Oct 2016
Location: Massachusetts
Posts: 365
Quote:
Originally Posted by jetchlnger View Post
New here, have a number of Sigs I've been shooting for a few years. Just picked up the Mk25 RX and took it to the range. Weapon shoots beautifully and is dead on using the irons as I would expect. The Romeo 1 shuts off after a couple of rounds and I wasn't able to zero the sight as it would not respond in either elevation or windage. Called Sig, slide is in the mail to them tomorrow. Anyone else had this problem? Thanks.
Meaning the adjustment dials on the top and side didn't move the dot location at all? Very strange if so.
DPeter85 is online now  
Old 01-09-2017, 07:35 PM   #6
Junior Member
 
Join Date: Apr 2015
Location: Newnan Ga
Posts: 3
That's correct, dot never moved.
jetchlnger is offline  
Old 01-16-2017, 05:37 AM   #7
Senior Member
 
Join Date: Dec 2014
Location: Springfield, VA
Posts: 334
If the dot shuts off after a few rounds then you need to tighten down the battery cap. The supplied tool doesn't allow for enough torque. Use a real screw driver and tighten it another quarter turn. You need between 5 and 10 inch pounds of torque.
Alma is offline  
Old 03-19-2017, 07:38 AM   #8
Member
 
Join Date: Sep 2014
Location: USA
Posts: 86
got my 226RX yesterday. went thru 2 batteries already. lasts about 1 hour and then dot dims and turns of. QC issues for sure, as it now has to go back to sig. not confidence inspiring in an otherwise excellent pistol.
vactor is offline  
Reply

  SIG Talk > SIG Sauer Forum > Sig Sauer Optics & Electronics


Search tags for this page

battery issues with sig romeo 1

,

sig romeo 1 problems

,

sig romeo 1 shuts off

,

sig romeo sight not working

,

sigoptics problems

,

will sig romeo 1 turn on while carrying

Click on a term to search for related topics.

Thread Tools
Display Modes


Similar SIG Talk Discussions
Thread Thread Starter Forum Replies Last Post
Romeo1 reflex sight sting6t5 SIG Sauer Pistols 0 10-02-2016 06:24 AM
What do you get when a wheel rolls over a Wilson and picks up a second M9A3 instead ShipWreck Guns 23 09-07-2016 03:56 PM
Cabela's SIG Sauer P320 Pistol Includes ROMEO1 Mini Reflex Sight gundrted SIG Sauer Pistols 0 08-31-2016 02:43 PM
TFO front sight on P320F DCS P250 & P320 Modular Pistols 5 08-13-2016 05:36 AM
Added a SIG X-Ray Front Sight To My P320 Compact>>>>>>>> Rolex John P250 & P320 Modular Pistols 19 07-17-2016 09:15 AM


Top Gun Sites Top Sites List

Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
Copyright © 2010 - 2017 SIG Talk. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.SIG Talk is a SIG Sauer Firearms enthusiast's forum, but it is in no way affiliated with, nor does it represent SIG Sauer, Inc. of Exeter, NH.